air not switching after recalibration.

ID Status Date Year Make Model Transmission Type A/C Controls Public/Private
#14039 Closed 2002 Chevy 1500HD public

I put a new stereo in my 02 silverado. I had to remove the air control panel to get to one of the harnesses. After putting it all back together, my air only blew hot regardless of temperature selection. However the locatio
Would switch properly (defrost, feet, etc.) I found a video online with a link to this site about doing an actuator recalibration. I removed the battery cables for 90 seconds, hooked them back up, ran truck for 60 seconds while NOT touching the air controls. Turned it off, wait so 10 seconds and turned it back on. The air started switch temperatures as I told it to, cold and hot worked perfectly.
However, now the air selector wont change off the defroster. I recalibrated it 2 more times and nothing changed. The temp selector is working great, but not the location selector (I’m sure that’s not the official term).
Any ideas??

However the location wouldnt* switch properly.


The older vehicles required more time. I would try doing the recalibration again but allow the engine to run for 2 to 3 minutes before proceeding to the next step.

I will give that a try this evening and report back.
Thanks for the help!!

I had some free time and tried it 2 more times, for a longer duration. No change on the selector. And on the last one, the temperature is not changing now.
Any thoughts?



Probably time to replace the actuators.  The position one is called a mode actuator and the other is the temperature door actuator.

I did notice that I can hear the mode actuator turning whenever I move the selector. It’s like it just isn’t moving enough or in the wrong direction to get it off defrost.

I was able to fix it. Turns out the gear to mode actuator and the white gear to the mode door were rotated too far towards the cab. I assume it “thought” it was in the panel vent selection because when I would move the selector from upper panel to defroster, it would rotate further towards the cab. The gear off the actuator and off the mode door wouldn’t touch.
I was able to reach up there and push the gears back towards the firewall, with the selector moved to the upper panel mode. It works fine now.
Thanks for the help, hopefully this helps someone else too.


Thanks for posting your findings.

Write a reply

The ticket has been closed. If you feel that your issue has not been solved yet or something new came up in relation to this ticket, you can re-open it by clicking this link.